Generated when trying to lookup a gem to indicate that the gem was found, but that it isn't usable on the current platform.

fetch and install read these and report them to the user to aid in figuring out why a gem couldn't be installed.

Methods
A
N
W
Attributes
[R] name
[R] platforms
[R] version
Class Public methods
new(name, version)
# File lib/rubygems/errors.rb, line 15
def initialize(name, version)
  @name = name
  @version = version
  @platforms = []
end
Instance Public methods
add_platform(platform)
# File lib/rubygems/errors.rb, line 21
def add_platform(platform)
  @platforms << platform
end
wordy()
# File lib/rubygems/errors.rb, line 25
def wordy
  prefix = "Found #{@name} (#{@version})"

  if @platforms.size == 1
    "#{prefix}, but was for platform #{@platforms[0]}"
  else
    "#{prefix}, but was for platforms #{@platforms.join(' ,')}"
  end
end