This is test for [ruby-Bugs#3237]

Required Files
Namespace